Search found 48 matches

by quacksapup
Sun Mar 30, 2014 11:02 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

PyTom wrote:Can someone put together a replication exhibiting the problem? I'd like to go and debug it.
Actually, uninstalling and then reinstalling worked. My main menu is back to normal!
Maybe it was something that glitched between updates?
by quacksapup
Sun Mar 30, 2014 10:36 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

Does anyone know why my main menu was skipped after I went back to the new-style imagemap code? When I loaded Mugen's GUI, it also skipped his main menu. Is this just me? Did anyone else try the GUI? Mugen's project doesn't do that, and neither does your example. There is nothing in either that wou...
by quacksapup
Sun Mar 30, 2014 10:25 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

Does anyone know why my main menu was skipped after I went back to the new-style imagemap code? When I loaded Mugen's GUI, it also skipped his main menu. Is this just me? Did anyone else try the GUI?
by quacksapup
Sun Mar 30, 2014 7:59 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

I went back to the new style, and now the main menu is skipped entirely.
by quacksapup
Sun Mar 30, 2014 7:53 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

Paste your code. Got it. Your old code is new-style and your new code is old-style.. did you get them switched around, or did you actually move from new-style to old-style? Anyway, with the new-style code there, all I could really suggest is supplying an idle image (use the existing ground image as...
by quacksapup
Sun Mar 30, 2014 7:41 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

I took a look at your code and found that you're using the new-style imagemap syntax. You see, I'm still using the old-style syntax I was using the old style, which was giving me the glitchy stuff you were experiencing as well. But when I converted to the new style, I got random, floating bars. And...
by quacksapup
Sun Mar 30, 2014 7:35 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

Ivlivs wrote:I should be able to convert it into the new-style syntax easily enough, but how do you change the messages for "ARE_YOU_SURE", etc. and such?
See if this helps:
http://www.renpy.org/wiki/renpy/doc/ref ... sno_prompt
by quacksapup
Sun Mar 30, 2014 7:30 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

I took a look at your code and found that you're using the new-style imagemap syntax. You see, I'm still using the old-style syntax I was using the old style, which was giving me the glitchy stuff you were experiencing as well. But when I converted to the new style, I got random, floating bars. And...
by quacksapup
Sun Mar 30, 2014 7:03 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

OK, everyone... download this and try this in your local Ren'py copies and tell us if the problem is duplicated in this one... http://lemmasoft.renai.us/forums/download/file.php?id=19888 "POOF" (Disappears) I didn't run into any problems with this. Unless you intentionally had it skip the main menu...
by quacksapup
Sun Mar 30, 2014 5:26 pm
Forum: Ren'Py Questions and Announcements
Topic: Imagemap menus are broken in Ren'Py 6.17.3
Replies: 35
Views: 3135

Re: Imagemap menus are broken in Ren'Py 6.17.3

I have the same problem happening with my game... and all the codes are correct. I have no idea what's going on!
I also deleted my cache, and it didn't help. The weird thing with mine is... there's weird floating bars and you have to click on those rather than the actual button itself.
by quacksapup
Sun Mar 30, 2014 5:13 pm
Forum: Ren'Py Questions and Announcements
Topic: Multiple main menu music?
Replies: 1
Views: 316

Multiple main menu music?

Hey guys, Is it possible to change the default music just like you can change the main menu background? I have multiple backgrounds for when more characters role in, and each background has its own music. Also, is there a way to save the music box settings so that the default song doesn't always pla...
by quacksapup
Sat Feb 15, 2014 8:24 pm
Forum: Ren'Py Questions and Announcements
Topic: Sounds aren't working? [SOLVED]
Replies: 11
Views: 977

Re: Sounds aren't working?

xela wrote: Well, you see... that's scary because I can only imagine what a professional software output might be like :lol: Anything simple soft throws up seems to work fine with Ren'Py.
It'll be okay. The volume on the converted sounds are the same even after export. :^]
by quacksapup
Sat Feb 15, 2014 8:13 pm
Forum: Ren'Py Questions and Announcements
Topic: Sounds aren't working? [SOLVED]
Replies: 11
Views: 977

Re: Sounds aren't working?

So I just tried that out. The song is .mp3 and I switched it from 'play music' to 'play sound' and it worked anyway. The sfx are in my play statement. So perhaps maybe it is something to do with the .wav. WAV (uncompressed PCM only) Just find any converter online or offline and covert your files fr...
by quacksapup
Sat Feb 15, 2014 8:11 pm
Forum: Ren'Py Questions and Announcements
Topic: Sounds aren't working? [SOLVED]
Replies: 11
Views: 977

Re: Sounds aren't working?

Yeah, I'm saying that because the music is working, if the sound channel isn't working you should be able to change 'play music' to 'play sound' and the music will stop working. If it still plays, it's a problem with your sound or you've put the sound file in the wrong place. Anyway, Shift+D, click...
by quacksapup
Sat Feb 15, 2014 8:03 pm
Forum: Ren'Py Questions and Announcements
Topic: Sounds aren't working? [SOLVED]
Replies: 11
Views: 977

Re: Sounds aren't working?

Yeah, I'm saying that because the music is working, if the sound channel isn't working you should be able to change 'play music' to 'play sound' and the music will stop working. If it still plays, it's a problem with your sound or you've put the sound file in the wrong place. Anyway, Shift+D, click...