Page 2 of 3

Re: Is the Forum Search laggy / borken for everyone?

Posted: Tue Feb 13, 2018 2:42 pm
by verysunshine
Search has been timimg out fairly regularly to a "cannot connect to server" error. Sometimes the "your post" / "egosearch" page will only bring up the 3 most recent posts.

Googling and filtering the results fir just lemmasoft doesn't appear to be as effective as I would like, but it's functional.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Tue Feb 13, 2018 6:46 pm
by rayminator
i am getting white blink page

Re: Is the Forum Search laggy / borken for everyone?

Posted: Tue Feb 13, 2018 8:04 pm
by LateWhiteRabbit
Yeah, the forum search hasn't worked for me in a long time. I use the work around verysunshine does of using Google with filters, but it still isn't very efficient. It's a shame, because a lot of good Ren'Py knowledge is here on the forums, but isn't easily found anymore. Several times over the past few days I've just had to manually go through all the pages in the forum and hope people have created good topic titles .... not a very efficient way to look for help.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Thu Feb 15, 2018 1:01 am
by Green Glasses Girl
rayminator wrote:
Tue Feb 13, 2018 6:46 pm
i am getting white blink page
Same. I've had this issue for several weeks now and it's been very frustrating trying to navigate the forum to find anything. I hope this gets fixed soon.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Thu Feb 15, 2018 4:40 pm
by PyTom
Can people post searches that are broken? Its been working for me, which is why this is weird.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Thu Feb 15, 2018 4:43 pm
by Imperf3kt
Yeah, I've had no troubles at all here.
Guess I've been lucky?

Re: Is the Forum Search laggy / borken for everyone?

Posted: Thu Feb 15, 2018 6:23 pm
by rayminator
Here my searches

textbutton into an image
gallery
cg gallery
how to add main menu into gallery

sometime it works then sometime goes to white blink page

here I have upload a video to show you

https://www.youtube.com/watch?v=aI4noOT ... e=youtu.be

Re: Is the Forum Search laggy / borken for everyone?

Posted: Thu Feb 15, 2018 6:25 pm
by verysunshine
I seem to get it to work on a regular search, but advanced searches are more variable. Could it be an internet problem?

Re: Is the Forum Search laggy / borken for everyone?

Posted: Fri Feb 16, 2018 9:21 pm
by Green Glasses Girl
PyTom wrote:
Thu Feb 15, 2018 4:40 pm
Can people post searches that are broken? Its been working for me, which is why this is weird.
My last search was "adding background music" - received a blank page.

I'm wondering if searching anything with multiple spaces in it might be causing the error. For example, searching "button" leads to a list of results, but searching something like "button system time" leads to a blank page? Maybe, maybe not? I'll do more searches.

EDIT: Scratch that theory. Searching for "Magicians of Delphine" gets results, searching "script sprite file" gets another blank page. Not sure what is happening.

On my end:

Searches that failed: (led to blank page)
adding background music
background music
gui script format

Searches that worked:
sprite (roughly 30k results, loaded fast)
renpy update (roughly 1k results, loaded slow)
character design
gallery
typeface (took a very long time to load)

Browser: Mozilla Firefox 56.0.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Thu Feb 22, 2018 9:40 am
by ComputerArt.Club
I am a little embarrassed to share my search history, but I will contribute if it helps.

Searches today that didn't work:
favorite visual novel
best visual novel

Perhaps there were too many hits or the server just decided I was searching for something that was too crass. The error message was different than before: This page isn’t working
lemmasoft.renai.us is currently unable to handle this request.
HTTP ERROR 500.

This was on Chrome 63.0.3239.132 (Official Build) (64-bit)

The thing that usually triggers an error is probably "your posts" or something similar, I think they tend to trigger "504 gateway time-out error" more often. I've been away for the last two to three weeks however, so I haven't been particularly active recently.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Sat Mar 03, 2018 10:41 pm
by Katy133
Today, I got this error page when I tried to search: gettooltip()
General Error

SQL ERROR [ postgres ]

ERROR: syntax error in tsquery: "gettooltip() " []

SQL

SELECT p.post_id FROM phpbb_posts p WHERE (to_tsvector ('english', p.post_subject || ' ' || p.post_text) @@ to_tsquery ('english', 'gettooltip() ')) AND p.forum_id NOT IN (14, 34, 35, 39, 40, 71) AND (p.forum_id NOT IN (14, 39, 71, 34, 40, 35) AND p.post_visibility = 1) ORDER BY p.post_time DESC LIMIT 250 OFFSET 0

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/postgres.php
LINE: 194
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/postgres.php
LINE: 258
CALL: phpbb\db\driver\postgres->sql_query()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 270
CALL: phpbb\db\driver\postgres->_sql_query_limit()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 321
CALL: phpbb\db\driver\driver->sql_query_limit()

FILE: [ROOT]/phpbb/search/fulltext_postgres.php
LINE: 540
CALL: phpbb\db\driver\factory->sql_query_limit()

FILE: [ROOT]/search.php
LINE: 593
CALL: phpbb\search\fulltext_postgres->keyword_search()

Re: Is the Forum Search laggy / borken for everyone?

Posted: Fri Apr 27, 2018 12:30 am
by ComputerArt.Club
This page isn’t working
lemmasoft.renai.us is currently unable to handle this request.
HTTP ERROR 500

after searching for "two splashscreens",
and "two presplashscreens"

The following searches worked:
"two"
"splashscreens"
"borken"(sic)
"presplashscreens"

I then tried "two splashscreens" and "two presplashscreens" again and it failed again.

Chrome Version 65.0.3325.181 (Official Build) (32-bit)

I'm still having problems with the "my posts" button too I think I noticed that switching between desktop mode and mobile mode on my phone affected this, though I didn't write down the details.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Fri Apr 27, 2018 8:44 pm
by Remix
Went scampering to find which database the forum sat on and found... Tom's shadow (and a deer apparently)...
Image
I had to share ;)

On topic: It might actually make sense to archive posts older than say 2 years into a mirror database (or legacy sub-domain) that general searches do not target... With legacy gui and the advent of Ren'py 7.0 just here, thousands of old posts and threads just are not relevant any more.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Sat Apr 28, 2018 12:41 am
by LateWhiteRabbit
Remix wrote:
Fri Apr 27, 2018 8:44 pm
On topic: It might actually make sense to archive posts older than say 2 years into a mirror database (or legacy sub-domain) that general searches do not target... With legacy gui and the advent of Ren'py 7.0 just here, thousands of old posts and threads just are not relevant any more.
This is actually a great idea. The Ren'py Questions posts should definitely be archived beyond a certain date and made inaccessible to general searches. It is kind of terrible when you search a coding question on Ren'py you get results from 6-7 years ago that are no longer relevant or just plain old BAD PRACTICE now.

Just a few weeks ago I was searching for a solution to problem (using Google - because see the topic we are in) and got a top search result to a Lemmasoft thread where PyTom gave some code to do what I wanted. Great! Except it didn't work ... and when I looked at the date and saw how old the post was, I knew why. Cut to 20 minutes later and I eventually found the answer by searching the Ren'Py documentation, which had a code sample VERY similar, but with the all important updated changes that made it work in the current version of Ren'Py. :roll:

I know PyTom has been making a big effort to teach best practices lately with his Ren'Py articles and posts - because a lot of bad behavior from the engine is developer-error for using out-dated or bad practices - but how much are nearly a decade's worth of old Ren'Py coding posts contributing to the problem? Might be time to wall them off in their own secret garden for historical posterity.

Re: Is the Forum Search laggy / borken for everyone?

Posted: Fri Jul 20, 2018 3:54 pm
by trooper6
Just checking in to day that I'm having search issues July 2018. I'll do an advanced search and the result will just be a black want screen with nothing on it. No errors...just a blank screen.