Memory leak via surface on Raspberry Pi

In this forum we discuss the future of Ren'Py, both bug fixes and longer-term development. Pre-releases are announced and discussed here.
Post Reply
Message
Author
User avatar
Imperf3kt
Eileen-Class Veteran
Posts: 1951
Joined: Mon Dec 14, 2015 5:05 am
Location: Your monitor
Contact:

Memory leak via surface on Raspberry Pi

#1 Post by Imperf3kt » Sun Nov 26, 2017 1:49 am

This issue only began appearing since I updated to Raspbian Stretch, so it may be an issue my end or it may be an issue with Debian 9. Everything worked very smoothly in Raspbian Jessie (Debian 8.3)

As some of you may know, I am working on making the Raspberry Pi a viable platform for playing Ren'Py games in a portable fashion without the need to rely on Android versions (which don't always exist) or an expensive Windows tablet.
This has been a challenge and along the way I've made some good progress.

Now with that quick bit of circumstances explained, I have run into an error that may be related to the Operating system or may be a flaw with the version of Ren'Py I have.

Lately, whenever I run any games, I see the performance warning, telling me Ren'Py is using software rendering. This means hardware acceleration is not being used and as a result, Ren'Py runs painfully slow.

After continuing past the error, I see the following in the terminal while running any games (including "The Question")
Image

I assume this is directly related to not having hardware acceleration, but it may also be due to the fact I am running Ren'Py 7.1.0.0

This error does not appear to trigger every time. Its occasion seems to be completely random and I cannot see any pattern in its appearance.

Does anybody else who uses a Raspberry Pi have the same issue, or am I alone in this matter?
Warning: May contain trace amounts of gratuitous plot.
pro·gram·mer (noun) An organism capable of converting caffeine into code.

Post Reply

Who is online

Users browsing this forum: No registered users