Bug when using the latest release of ren'py

In this forum we discuss the future of Ren'Py, both bug fixes and longer-term development. Pre-releases are announced and discussed here.
Post Reply
Message
Author
User avatar
Meg'
Regular
Posts: 153
Joined: Tue Sep 27, 2011 10:37 am
Projects: Anges Démoniaques, Gang
Location: France
Contact:

Bug when using the latest release of ren'py

#1 Post by Meg' » Wed Dec 13, 2017 4:50 am

Hi!

I installed the latest version of ren'py and decided to use it to make an update of my game for android. The thing is I'm encountering a bug:

Code: Select all

Updating source code.

Updating build files.
Resolved location of library project to: D:\renpy-6.99.12.4-sdk\rapt\extras\google\market_apk_expansion\downloader_library
Updated and renamed default.properties to project.properties
Updated local.properties
Added file D:\renpy-6.99.12.4-sdk\rapt\build.xml
Updated file D:\renpy-6.99.12.4-sdk\rapt\proguard-project.txt
It seems that there are sub-projects. If you want to update them
please use the --subprojects parameter.




Creating assets directory.

Creating expansion file.

Packaging internal data.

I'm using Ant to build the package.
Buildfile: D:\renpy-6.99.12.4-sdk\rapt\build.xml

-set-mode-check:

-set-release-mode:

-release-obfuscation-check:
     [echo] proguard.config is ${proguard.config}

-pre-build:

-check-env:
 [checkenv] Android SDK Tools Revision 24.4.1
 [checkenv] Installed at D:\renpy-6.99.12.4-sdk\rapt\android-sdk-r24.4.1

-setup:
     [echo] Project Name: Gang_Hugo-1.1
  [gettype] Project Type: Application

-build-setup:
[getbuildtools] Using latest Build Tools: 23.0.1
     [echo] Resolving Build Target for Gang_Hugo-1.1...
[gettarget] Project Target:   Android 5.1.1
[gettarget] API level:        22
     [echo] ----------
     [echo] Creating output directories if needed...
     [echo] ----------
     [echo] Resolving Dependencies for Gang_Hugo-1.1...
[dependency] Library dependencies:
[dependency] 
[dependency] ------------------
[dependency] Ordered libraries:
[dependency] 
[dependency] ------------------
     [echo] ----------
     [echo] Building Libraries with 'release'...

nodeps:

-set-mode-check:

-set-release-mode:

-release-obfuscation-check:
     [echo] proguard.config is ${proguard.config}

-pre-build:

-check-env:
 [checkenv] Android SDK Tools Revision 24.4.1
 [checkenv] Installed at D:\renpy-6.99.12.4-sdk\rapt\android-sdk-r24.4.1

-setup:
     [echo] Project Name: library
  [gettype] Project Type: Android Library

-build-setup:
[getbuildtools] Using latest Build Tools: 23.0.1
     [echo] Resolving Build Target for library...

BUILD FAILED
D:\renpy-6.99.12.4-sdk\rapt\android-sdk-r24.4.1\tools\ant\build.xml:597: The following error occurred while executing this line:
D:\renpy-6.99.12.4-sdk\rapt\android-sdk-r24.4.1\tools\ant\build.xml:538: Unable to resolve project target 'android-15'

Total time: 0 seconds




The build seems to have failed.
I think the errors are not linked to my project (I'm not 100% sure) because I tried to use the previous version of ren'py (aka 6.99.12.4.2187) and didn't encounter the bug. The build worked perfectly.

So any idea what could be causing this error? Or could it be an error linked to my project that the previous version of ren'py didn't detect and the actuel does?

Thank you for your help :D
Image

User avatar
Imperf3kt
Eileen-Class Veteran
Posts: 1482
Joined: Mon Dec 14, 2015 5:05 am
Location: Your monitor
Contact:

Re: Bug when using the latest release of ren'py

#2 Post by Imperf3kt » Wed Dec 13, 2017 4:05 pm

Sounds very similar to a problem I had a while ago.

viewtopic.php?f=8&t=45820&hilit=failed
Image

Warning: May contain trace amounts of gratuitous plot.
pro·gram·mer (noun) An organism capable of converting caffeine into code.

Post Reply

Who is online

Users browsing this forum: No registered users