Page 1 of 1

Can't get Ren'Py 7.2.1 to run on OSX 10.13.6

Posted: Sun Mar 17, 2019 1:46 pm
I posted this in the Announcements thread, but maybe it should be in this one, so am reposting here.

I can not get Ren'Py 7.2.1 to run on my Mac. 7.1.0 was already installed and runs fine. I know how to get around the issue that the Mac doesn't want to run apps it isn't familiar with so that isn't the problem.

I have downloaded 7.2.1 at least 5 times both DMG and ZIP versions. When I install the SDK folder from the DMG, right-click the app and launch, I get a warning that the file is corrupted and a prompt to delete it. This happens every time, and I have even tried DLing to different HDs and using different browsers to be sure. When I install the SDK from the ZIP, right-click the app and open, it tries to launch after verifications, but just stops. After this, trying to launch only causes the app to bounce once in the Dock, but then nothing else happens. No messages, no crash reports, nothing.

I do have Norton Anti-virus running, but in its logs I can't see any indication that it is reacting at all to Ren'Py, and as I have indicated, the last version I DLed works fine.

If anyone can help, I'd be grateful. I'm actually on the verge of trying to seriously use Ren'Py for the first time and gearing up soon to help my daughter learn to use it for her HS senior project, so it suddenly being broken for me is distressing.

Re: Can't get Ren'Py 7.2.1 to run on OSX 10.13.6

Posted: Sun Mar 17, 2019 7:37 pm
Thanks to everyone that took a look at my issue!

PyTom solved my problem with his answer to my post in the Questions and Announcements thread.