Page 1 of 1

(Suggestion) Add Support for API Level 19

Posted: Fri Jul 05, 2019 11:08 am
by C00ljav
Hi, from renpy 7.3.0, the new renpy libraries doesnt support API level 19 to play renpy games on old android devices (Android 4.4), its there any way to resume the support for this devices? Some people, like me, have an old tablet that its perfect for play this kind of games, but now is not supported.
Please, is there anychance to see compability with old devices again? With old version focus-mask isnt working. :(

Re: (Suggestion) Add Support for API Level 19

Posted: Fri Jul 05, 2019 11:58 pm
by Imperf3kt
Unfortunately not. This was a forced change implemented by Google.

Re: (Suggestion) Add Support for API Level 19

Posted: Sat Jul 06, 2019 12:08 am
by PyTom
It's not. The target API change was, but not the minAPI.

I made the change so we could support 64-bit platforms. I'll look to see if I can revert it for ARM devices, but no promises - we're talking about > 5 year old tablets at this point.

Re: (Suggestion) Add Support for API Level 19

Posted: Sat Jul 06, 2019 6:57 am
by C00ljav
Thanks, for the try.
If you cant revert it, at least is there anyway to make the new libraries for android compatible with API 19?