Testers Needed for MP3 problem.

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Message
Author
User avatar
Rika-chan
Regular
Posts: 48
Joined: Sun Aug 06, 2006 2:01 pm
Contact:

#31 Post by Rika-chan » Tue Aug 08, 2006 1:32 pm

I tried it on my computer, but I couldn't make it crash. I'm a little disappointed. I was really hoping it would so that I could help. I did what you recommended, scrolling back, then skipping forward (over 100 times, I'm sure); skipping through the program over and over; restarting the program, then doing the same; and finally restarting, taping down ctrl and leaving it for 20 minutes.

My computer specs:
AMD Athlon 64 3400
1 GB RAM
nVidia GeForce 6600 GT
Realtek AC'97 Integrated Soundcard
WinXP Pro SP2

Let me know if you need more info.

User avatar
monele
Lemma-Class Veteran
Posts: 4101
Joined: Sat Oct 08, 2005 7:57 am
Location: France
Contact:

#32 Post by monele » Tue Aug 08, 2006 2:46 pm

Code: Select all

if player=="mikey":
    jump crash
?

That wouldn't be very nice :/. In any case though, we *do* have some sort of idea of what configuration causes the problem now, right ?

User avatar
PyTom
Ren'Py Creator
Posts: 15447
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#33 Post by PyTom » Tue Aug 08, 2006 3:35 pm

monele wrote:That wouldn't be very nice :/. In any case though, we *do* have some sort of idea of what configuration causes the problem now, right ?
Yes. Unfortunately, we have no idea _why_.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

BlackSpider
Regular
Posts: 133
Joined: Fri Aug 22, 2003 1:08 pm
Location: Wroclaw, Poland
Contact:

#34 Post by BlackSpider » Mon Aug 14, 2006 8:04 am

Well I tryed it on my PC and couldn't make it crash either. For over 15min I was scrolling back and forward, switching to windowed, fullscreen, restarting the program. But still no crash... WinXP SP2 PL, CelD 2.5Ghz, 512MB RAM with onboard Intel AC97 sound.

BTW when I have strange problems either with sound or graphics usually installing the latest drivers, then DirectX 9.0c helps. From my experience though, drivers found on the Microsoft update website (or those that Windows installs by default) are not always the best ones. IMO it's a sound driver related issue but I may be wrong of course.

User avatar
Jake
Support Hero
Posts: 3826
Joined: Sat Jun 17, 2006 7:28 pm
Contact:

#35 Post by Jake » Thu Aug 17, 2006 8:06 pm

I remembered I had a laptop that I totally forgot to test, but couldn't get it to crash on that, either - WinXP Tablet Edition (Pro with shiny bits), Cirrus Logic Crystal WDM Audio sound.
Server error: user 'Jake' not found

User avatar
PyTom
Ren'Py Creator
Posts: 15447
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#36 Post by PyTom » Thu Aug 17, 2006 8:14 pm

Personally, I think it might be a cpu issue related to the P4. But don't quote me on that... I don't see how it could be a driver issue, as ogg music plays fine on the affected systems.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

User avatar
Jake
Support Hero
Posts: 3826
Joined: Sat Jun 17, 2006 7:28 pm
Contact:

#37 Post by Jake » Thu Aug 17, 2006 8:34 pm

PyTom wrote:Personally, I think it might be a cpu issue related to the P4. But don't quote me on that...
That reminds me, I forgot the processor, sorry; the tablet is a "Pentium M ULV 1GHz", but... my desktop is a P4 and I couldn't get it to crash there, either. There's got to be a little more to it than that...
Server error: user 'Jake' not found

User avatar
PyTom
Ren'Py Creator
Posts: 15447
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#38 Post by PyTom » Fri Aug 18, 2006 10:32 am

I've uploaded a new version of renpy.code to:

http://www.bishoujo.us/tmp/renpy.code

Could people who have had the problem drop this version in, and see if it fixes anything? Thanks.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

BlackSpider
Regular
Posts: 133
Joined: Fri Aug 22, 2003 1:08 pm
Location: Wroclaw, Poland
Contact:

#39 Post by BlackSpider » Fri Aug 18, 2006 11:03 am

I like unexplained mysteries so here comes my last idea on this mp3 problem :P I remember that some time ago when I was using ffdshow filter (AFAIK it has some postprocessing capabilities) I had strange issues with software using mp3 compression. I don't know if it's possible to disable mp3 postprocessing if you have ffdshow installed and experience the bug but it might be worth a try.

User avatar
PyTom
Ren'Py Creator
Posts: 15447
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#40 Post by PyTom » Fri Aug 18, 2006 11:21 am

Codecs shouldn't be a problem, as Ren'Py ships with all codecs it needs. The only windows API it uses is the WaveOut api (and similar low-level APIs for the mixer and midi functions). It doesn't touch DirectX or the like, or at least it shouldn't.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

User avatar
mikey
Lemma-Class Veteran
Posts: 3249
Joined: Sat Jan 10, 2004 6:03 am
itch: atpprojects
Contact:

#41 Post by mikey » Fri Aug 18, 2006 1:17 pm

PyTom wrote:Could people who have had the problem drop this version in, and see if it fixes anything? Thanks.
:( It doesn't. Not for me.

User avatar
PyTom
Ren'Py Creator
Posts: 15447
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#42 Post by PyTom » Wed Aug 30, 2006 6:25 pm

Okay, I have another attempted fix for the mp3 problem. I've swapped out smpeg for mpglib in SDL_sound. If the problem was in SMPEG, then this might fix the problem.

The new version is at:

http://www.bishoujo.us/tmp/crashme2.zip

If people who had the problem before could try this out, I'd appreciate it.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

User avatar
mikey
Lemma-Class Veteran
Posts: 3249
Joined: Sat Jan 10, 2004 6:03 am
itch: atpprojects
Contact:

#43 Post by mikey » Wed Aug 30, 2006 7:53 pm

I wasn't able to crash this one (crashme2), on Onyx, or on Mayako. I tried it all, going back and forth, cycling the script, reload, restart, everything.

I then re-downloaded the original crashme and on both computers it crashed in a matter of moments.

So I tried everything a couple of times more, and the crashme version always locked up in under 30 seconds, while the crashme2 versions kept on going forever. As we speak, the one on Mayako is still running.

So whatever you did, it most probably worked. :P
Sorry if I'm not too enthusiastic yet, I have still to realize that the nightmare is probably over.

PS: I also tried to use the crashme2 files with our final version of Ori Ochi Onoe - first I only replaced the oggs with mp3s and as suspected, it crashed the game in a few seconds. I then copied everything except the [game] folder of crashme2 over the final Ori Ochi Onoe version (as to "update" it), but the game wouldn't start, probably some version mismatch (traceback reported something like KeyError: insensitive_enable.hover). So I couldn't test it with O3.

User avatar
PyTom
Ren'Py Creator
Posts: 15447
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#44 Post by PyTom » Wed Aug 30, 2006 10:36 pm

Basically, what I did was to totally change out the mp3 decoding library, for a different one, one that hopefully works a bit better. It seems to have solved the problem, bully.

The new version is based off of 5.6, and I'm still tweaking the backwards compatibility on it. My goal for 5.6 is that we will have reasonable backwards compatibility... I made a number of changes that are hard to get perfectly backwards compatible, so there might be glitches in some games.

(If you can edit a script, it should be easy to make the game 100% compatible.)
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

Post Reply

Who is online

Users browsing this forum: Adrian_DVL, fullmontis, Google [Bot], Majestic-12 [Bot], MaydohMaydoh, noeinan