[solved]problem with sideimage

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
k i r a
Regular
Posts: 34
Joined: Sat Nov 04, 2006 9:39 pm
Contact:

[solved]problem with sideimage

#1 Post by k i r a » Sun Sep 18, 2011 4:26 pm

hi,

I was pretty interested in sideimage function, and tried using that in ren'py 6.12.2.

the first code works perfectly, but when I write "side" to indicate it's sideimage, it stops working, returning "undefined image".

code that works, but not what I want:

Code: Select all

image lynette naki1 s1 = "img/lynette/naki1s1.png"

label chap01:

    show lynette naki1 s1
the code that should show what I want, but doesn't:

Code: Select all

image side lynette naki1 s1 = "img/lynette/naki1s1.png"

label chap01:

    show lynette naki1 s1
what's happening? :(
Last edited by k i r a on Mon Sep 19, 2011 10:09 am, edited 1 time in total.

User avatar
zorexx
Newbie
Posts: 23
Joined: Thu Jun 23, 2011 7:15 am
Contact:

Re: problem with sideimage

#2 Post by zorexx » Sun Sep 18, 2011 5:50 pm

You have to put

Code: Select all

image="lynette"
in your character definition.
For example:

Code: Select all

define l = Character("Lynette", image="lynette")
and if you're only displaying side image without the full image, you don't need to use the "show" command.

In your case, you should do something like this:

Code: Select all

l naki1 s1 "Dialog here."

k i r a
Regular
Posts: 34
Joined: Sat Nov 04, 2006 9:39 pm
Contact:

Re: problem with sideimage

#3 Post by k i r a » Sun Sep 18, 2011 6:30 pm

thank you for reply!
I've forgotten to write, but I'd tried that too.........

the full code is

Code: Select all

image side lynette naki1 s1 = "img/lynette/naki1s1.png"

define l = Character('リネット', color = "#ffffff", image="lynette")

label chap01:

    show lynette naki1 s1
or

Code: Select all

image side lynette naki1 s1 = "img/lynette/naki1s1.png"

define l = Character('リネット', color = "#ffffff", image="lynette")

label chap01:

    l naki1 s1 "...."
if I erase the "side", it's shown, but as a normal image.
I really really don't know what's happening!
please help me!

User avatar
Aleema
Lemma-Class Veteran
Posts: 2677
Joined: Fri May 23, 2008 2:11 pm
Organization: happyB
Tumblr: happybackwards
Contact:

Re: problem with sideimage

#4 Post by Aleema » Sun Sep 18, 2011 7:01 pm

I haven't used this new side image system yet, but looking at the documentation, I see that the side image is defined *after* the character. Try moving "image side lynette naki1 s1" after "define l"? Also, the documentation says this:
If no image can be found, or more than one image has the same number of attributes, an Null is shown instead.
A Null is nothing. I'm not sure what "same number of attributes" means, though ... :(

User avatar
zorexx
Newbie
Posts: 23
Joined: Thu Jun 23, 2011 7:15 am
Contact:

Re: problem with sideimage

#5 Post by zorexx » Sun Sep 18, 2011 7:46 pm

The ordering doesn't matter.

Your second code is correct, and it works for me, what version of Ren'Py are you using? Have you tried downloading the latest version?

k i r a
Regular
Posts: 34
Joined: Sat Nov 04, 2006 9:39 pm
Contact:

Re: problem with sideimage

#6 Post by k i r a » Sun Sep 18, 2011 8:41 pm

thank you for reply!
I tried that right now, and no success...again.it continues with message "undefined images lynette naki1 s1".

User avatar
zorexx
Newbie
Posts: 23
Joined: Thu Jun 23, 2011 7:15 am
Contact:

Re: problem with sideimage

#7 Post by zorexx » Sun Sep 18, 2011 9:03 pm

Can you try pasting this code, replacing yours, and see if it works?

Code: Select all

define l = Character('Lynette', color = "#ffffff", image="lynette")

image side lynette naki1 s1 = "img/lynette/naki1s1.png"

# The game starts here.
label start:
    
    l naki1 s1 "....."
    
One more question, did you rewrite the "say" screen? Or are you using the default one?

k i r a
Regular
Posts: 34
Joined: Sat Nov 04, 2006 9:39 pm
Contact:

Re: problem with sideimage

#8 Post by k i r a » Mon Sep 19, 2011 10:08 am

it worked! thank you!

well, it doesn't work with show, but it's ok. The important is that it's shown now.

Thank you again for you all!!

User avatar
zorexx
Newbie
Posts: 23
Joined: Thu Jun 23, 2011 7:15 am
Contact:

Re: [solved]problem with sideimage

#9 Post by zorexx » Mon Sep 19, 2011 3:11 pm

No prob, glad to know it works.
Yes, you're not supposed to use show, if you want to show a normal image along with the side image (show both), you'll have to define another image:

Code: Select all

define l = Character('Lynette', color = "#ffffff", image="lynette")

image lynette naki1 s1 = "normal.png" #this one's for the normal version

image side lynette naki1 s1 = "side.png"

# The game starts here.
label start:

    show lynette naki1 s1

    l "....." # Notice I don't have to type "naki1 s1" here, this is because it is already set in the previous "show" command

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot]