libc.so.6: version `GLIBC_2.4' not found

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
Shavelle

libc.so.6: version `GLIBC_2.4' not found

#1 Post by Shavelle » Thu Dec 21, 2006 3:00 pm

I've searched for this on the forum, but didn't find any matches, so here goes.

I've been trying to run Ren'Py 5.6.5. on my Linux computer but it keeps giving me this:

libc.so.6: version `GLIBC_2.4' not found (required by /home/shavelle/Desktop/py4renpy-5.6.5/linux-x86/python.real)

I've tried several different things to get it to work, but with no results.

User avatar
PyTom
Ren'Py Creator
Posts: 15431
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#2 Post by PyTom » Thu Dec 21, 2006 3:31 pm

What version of linux are you using?
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

Shavelle

#3 Post by Shavelle » Thu Dec 21, 2006 3:51 pm

PyTom wrote:What version of linux are you using?
Ubuntu 6.06 Dapper Drake

User avatar
PyTom
Ren'Py Creator
Posts: 15431
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#4 Post by PyTom » Thu Dec 21, 2006 4:56 pm

Hm... I'm using Edgy Eft. I think the libc has been upgrade... I'll have to see what I can do to make it use the lower version.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

Shavelle

#5 Post by Shavelle » Thu Dec 21, 2006 5:41 pm

Oh, thank you. Sorry for the trouble.

Greg

#6 Post by Greg » Tue Mar 27, 2007 12:17 am

Hi, I'm continuing this old thread, because it was the only one I found in the search. Obviously I ran into the same problem as Shavelle.

This game runs fine:

Magical Boutique
http://lemmasoft.renai.us/forums/viewtopic.php?t=1853
(nominally Ren'Py 6.1.0 (pre-Beta release))

This game has the GLIBC version problem:

Drawn To You ~ Art School Romance
http://lemmasoft.renai.us/forums/viewtopic.php?t=1729
(nominally Ren'Py 5.6.7)

[Slackware 11.0, kernel 2.4.33.3, python version 2.4.3, glibc 2.3.6]

Any known workaround?

-Greg

User avatar
PyTom
Ren'Py Creator
Posts: 15431
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

#7 Post by PyTom » Tue Mar 27, 2007 12:48 am

Grab the new py4renpy from the renpy page, untar it, and use it to run the game. This was fixed a while back.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

greg
Newbie
Posts: 1
Joined: Tue Mar 27, 2007 10:22 pm
Contact:

#8 Post by greg » Tue Mar 27, 2007 10:41 pm

Indeed this seems to work. Thanks! -Greg

Post Reply

Who is online

Users browsing this forum: Google [Bot], tapanojum