Bug Replications

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Message
Author
User avatar
rayminator
Veteran
Posts: 261
Joined: Fri Feb 09, 2018 12:05 am
Projects: Redoing games to fix spelling mistakes other companys that don't care
Location: Canada
Contact:

Re: Bug Replications

#16 Post by rayminator » Mon Oct 21, 2019 11:48 am

There is something wrong with window show/hide the text and the textbox keep disappearing the textbox stays when using window show but not the text i have seen a couple of posts stating this problem I know there's an option tried everything and there is no change

is window show suppose to show the text and textbox when the image change and during a video showing?
is window hide suppose to hide the text and textbox when the image change and during a video showing?

I hope I make sense on this problem never had this problem with my last game that I done think it was when I used Ren'Py 6.99.14.2

User avatar
Angelo Seraphim
Newbie
Posts: 15
Joined: Tue May 21, 2019 8:00 am
Projects: Current: DCXVI: Charagma. Planned: Fall of Order, Teens After School, Jasmine and the Rascal Six
Organization: GLSUoA
Deviantart: glsuoa
itch: glsuoa
Location: London, UK
Contact:

Re: Bug Replications

#17 Post by Angelo Seraphim » Sun Oct 27, 2019 9:49 am

I don't know if it's my laptop (MacBook Pro) but I've recently noticed that whenever an animation or during some transitions, when you move the cursor (slow or rapidly), the framerate tanks and gives the illusion that the game is freezing. Does anyone else have this issue?
It also happens when you mouse over an imagebutton that has focus_mask True.

I've also noticed that some image animations like "my_image.png" with Dissolve(5, alpha=True) seem to be bugged. Some of these work as normal but others seem to just flip to the next image without dissolving. I've only noticed it happening when these images are then thrown into Composite . (I think this happens when the composited image is in a screen.)

I'm using RenPy version 7.3.5.606
My OS is Mojave 10.14.6 (Not sure if this really matters. I've always had this OS version but never had this issue with previous versions of RenPy on this.)
My game is still playable, it's just that rapidly moving the cursor causes the framerate to drop and is very noticeable.

I hope this makes sense. And I'll be happy to provide more details if needs be. Thanks. :D
Working my VN called "DCXVI: Charagma"
Website: http://grandlivingsoul.com

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot]