How to turn off vsync in Ren'Py?

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
bimb2212
Newbie
Posts: 19
Joined: Wed Jul 30, 2014 10:15 am
Contact:

How to turn off vsync in Ren'Py?

#1 Post by bimb2212 » Wed Jul 30, 2014 10:27 am

As the title, I want to turn off vsync in fullscreen mode. With vsync on in fullscreen, I got some lag spike when using ATL + mouse hovered on imagebutton, and some animation like zoom, transform, not smooth. But it is good in window mode.

User avatar
AxemRed
Veteran
Posts: 482
Joined: Sun Jan 09, 2011 7:10 am
Contact:

Re: How to turn off vsync?

#2 Post by AxemRed » Wed Jul 30, 2014 2:57 pm

vsync doesn't cause lag spikes. The most lag it can cause is 1 frame.

User avatar
bimb2212
Newbie
Posts: 19
Joined: Wed Jul 30, 2014 10:15 am
Contact:

Re: How to turn off vsync?

#3 Post by bimb2212 » Thu Jul 31, 2014 5:18 am

AxemRed wrote:vsync doesn't cause lag spikes. The most lag it can cause is 1 frame.
I mean, if a Background is transforming and repeat, then when you hover your mouse on 1 imagebutton, it causes 1 spike of lag (or can call it freezes in 0.1s), I hover on 3-4 imagebutton and repeat, it cause massive lag spikes consecutive on any ATL image. :(
Turn off vsync in nvidia Control Panel has fixed the problem. But I set default "Let the 3d application decide". Anyone know the way to turn off vsync in Ren'py? Add code or change some value...

Post Reply

Who is online

Users browsing this forum: Google [Bot]