ScriptError: could not find label

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
sempersapiens
Regular
Posts: 47
Joined: Mon Jun 30, 2014 4:31 pm
Location: Canada
Contact:

ScriptError: could not find label

#1 Post by sempersapiens » Wed Sep 24, 2014 10:48 pm

Maybe it's because it's late at night but I just have absolutely no clue what this is saying the problem is:
I'm sorry, but an uncaught exception occurred.

While running game code:
File "renpy/common/00start.rpy", line 81, in script
return
File "renpy/common/00start.rpy", line 81, in script
return
ScriptError: could not find label '(u'C:\\Program Files (x86)\\renpy-6.17.6-sdk\\Frost/game/main.rpy', 1411612774, 127)'.

-- Full Traceback ------------------------------------------------------------

Full traceback:
File "renpy/common/00start.rpy", line 81, in script
return
File "C:\Program Files (x86)\renpy-6.17.6-sdk\renpy\ast.py", line 1286, in execute
next_node(renpy.game.context().lookup_return(pop=True))
File "renpy/common/00start.rpy", line 81, in script
return
File "C:\Program Files (x86)\renpy-6.17.6-sdk\renpy\script.py", line 549, in lookup
raise ScriptError("could not find label '%s'." % str(label))
ScriptError: could not find label '(u'C:\\Program Files (x86)\\renpy-6.17.6-sdk\\Frost/game/main.rpy', 1411612774, 127)'.

Windows-7-6.1.7601-SP1
Ren'Py 6.17.6.512
It popped up while I was just messing around with some variables in my game, so I have no idea how I caused whatever this is. If someone can walk me through figuring out what's wrong and fixing it I'd be very grateful.

User avatar
Kaen
Regular
Posts: 148
Joined: Tue Oct 16, 2012 10:49 pm
Contact:

Re: ScriptError: could not find label

#2 Post by Kaen » Thu Sep 25, 2014 12:32 pm

You're probably using a jump statement to a label that was not declared.

User avatar
sempersapiens
Regular
Posts: 47
Joined: Mon Jun 30, 2014 4:31 pm
Location: Canada
Contact:

Re: ScriptError: could not find label

#3 Post by sempersapiens » Thu Sep 25, 2014 1:35 pm

Kaen wrote:You're probably using a jump statement to a label that was not declared.
Oh man I totally was! I'm so bad at programming. Thanks for the help. :)

Post Reply

Who is online

Users browsing this forum: Mjhay