Text Speed reverts back to "0" [SOLVED]

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
Llunet1
Regular
Posts: 55
Joined: Mon Oct 21, 2013 8:56 pm
Projects: Reminiscence, Blood
Deviantart: llunet1
Location: USA
Contact:

Text Speed reverts back to "0" [SOLVED]

#1 Post by Llunet1 » Sun Jun 14, 2015 2:26 pm

Hello!
Before I start, I would like to mention that I have looked around the forum and my problem is different from what I've seen answered to.
I changed my text speed to 35 in the options menu. Then, I deleted persistent, like I'm supposed to, and it initially worked. However, when I restart the game (close and reopen), the text speed reverts to 0 and in the preferences menu it's at the max. I have no idea why it does this! (If I delete persistent again, it repeats this cycle)

Has anyone encountered this problem before? Is there a solution to this?

(*Edit: When I delete persistent, launch the game, and then reload during the game, it also reverts the text speed to 0)
Last edited by Llunet1 on Mon Jun 15, 2015 12:16 pm, edited 1 time in total.

User avatar
Donmai
Eileen-Class Veteran
Posts: 1864
Joined: Sun Jun 10, 2012 1:45 am
Completed: Toire No Hanako, Li'l Red [NaNoRenO 2013], The One in LOVE [NaNoRenO 2014], Running Blade [NaNoRenO 2016], The Other Question
Projects: Slumberland
Location: Brazil
Contact:

Re: Text Speed reverts back to "0"

#2 Post by Donmai » Sun Jun 14, 2015 4:26 pm

If you want the default cps value to be 35, then you have to edit your 'options.rpy' file around line 280:

Code: Select all

    ## The default text speed in characters per second. 0 is infinite.

    config.default_text_cps = 35
And delete persistent.
Image
No, sorry! You must be mistaking me for someone else.
TOIRE NO HANAKO (A Story About Fear)

User avatar
Llunet1
Regular
Posts: 55
Joined: Mon Oct 21, 2013 8:56 pm
Projects: Reminiscence, Blood
Deviantart: llunet1
Location: USA
Contact:

Re: Text Speed reverts back to "0"

#3 Post by Llunet1 » Sun Jun 14, 2015 6:16 pm

I have done that. That's the problem. In the code that's how it is, and I have deleted persistent. The first time I launch the game, it works. But if I reload or relaunch the game, it goes to the max as if the text speed was at 0.

User avatar
nyaatrap
Crawling Chaos
Posts: 1824
Joined: Mon Feb 13, 2012 5:37 am
Location: Kimashi Tower, Japan
Contact:

Re: Text Speed reverts back to "0"

#4 Post by nyaatrap » Mon Jun 15, 2015 3:35 am

Are your game's options.rpy and screens.rpy based on the same ren'py version? If you mixed different version, there's a possibility that the same code is written in both files. Also delete old rpyc files if they are no more used.

User avatar
Llunet1
Regular
Posts: 55
Joined: Mon Oct 21, 2013 8:56 pm
Projects: Reminiscence, Blood
Deviantart: llunet1
Location: USA
Contact:

Re: Text Speed reverts back to "0"

#5 Post by Llunet1 » Mon Jun 15, 2015 12:15 pm

Hm. That might be what's causing it. The game was previously in another folder, and I copied it to Dropbox so I could work on it on other computers. So, in that way, perhaps stuff got mixed around and messed up.
I created a new project and copied over my files manually (going into script.rpy and copying it into the new one) and the problem seems to have been fixed!

Thank you! :)

Post Reply

Who is online

Users browsing this forum: nillan3