Looping an image

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
2chevsky
Newbie
Posts: 3
Joined: Sat Dec 03, 2016 12:57 pm
Contact:

Looping an image

#1 Post by 2chevsky » Fri Feb 10, 2017 2:54 pm

Hello.
I want to make animated background in main menu, and i done it, but there's some glitch, when image looping from start.
i dunno how to discribe that, heh.
https://drive.google.com/file/d/0B4YvWx ... sp=sharing here's a video of glitch.
transformation:

Code: Select all

init:
    transform _moveleft(delay=0.1):
        xalign 1.0
        linear delay xalign 0.0
        repeat
main menu screen:

Code: Select all

screen main_menu: 
    
    add "images/GUI/mainmenu/bg_ground.png" at _moveleft(15)
    add "images/GUI/mainmenu/bg_hover.png"
    imagemap:
        
        hover "images/gui/hover_menu1.png"        
        ground "images/gui/ground_menu.png"
        hotspot (1175, 484, 376, 90) action Start()
        hotspot (1223, 576, 342, 62) action ShowMenu("gallery")
        hotspot (1232, 640, 310, 60) action ShowMenu("preferences_table") 
        hotspot (1298, 698, 178, 75) action ShowMenu("gallery")

        hotspot (1294, 700, 190, 79) action Quit(confirm=True)

User avatar
gas
Miko-Class Veteran
Posts: 718
Joined: Mon Jan 26, 2009 7:21 pm
Contact:

Re: Looping an image

#2 Post by gas » Fri Feb 10, 2017 3:34 pm

It's not a transform problem, it's an image issue, that's not proper drawn for that kind of cycle.

The start of the image must be totally equal to the possible final frame... AND VICEVERSA.

i've done a diagonal movement of a squared background, with steps of 256 pixels

Code: Select all

transform bganime:
    xpos 0.0
    xanchor 0.0
    ypos 0.0
    yanchor 0.0
    linear 8.0 xpos -256  ypos -256 
    repeat
...and work perfectly.

if you're sure your image is well done, try something like, using xpos instead of xalign.
Attachments
mmenuanimebg.jpg
If you want to debate on a reply I gave to your posts, please QUOTE ME or i'll be not notified about.

10 ? "RENPY"
20 GOTO 10

RUN

User avatar
2chevsky
Newbie
Posts: 3
Joined: Sat Dec 03, 2016 12:57 pm
Contact:

Re: Looping an image

#3 Post by 2chevsky » Sat Feb 11, 2017 8:25 am

Some guy from VK has give me an advice.
Transform:

Code: Select all

init:
    transform _moveleft(time=9.0):
        xanchor 1.0 xpos 1.0
        linear time xanchor .5 xpos 1.0
        repeat
and then:

Code: Select all

screen main_menu: 
    window:
        xpadding 0
        ypadding 0
        add At(HBox("images/GUI/mainmenu/bg_ground1.png", "images/GUI/mainmenu/bg_ground2.png"), _moveleft(4))
        add "images/GUI/mainmenu/bg_hover.png"

Post Reply

Who is online

Users browsing this forum: No registered users