Broken Arabic even with config.rtl = true

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
asatiir
Regular
Posts: 86
Joined: Tue Oct 01, 2013 6:04 pm
Completed: Within the Walls (Twine)
Projects: Roses Will Rise
Organization: Asatiir's Tales
Skype: asatiir
itch: asatiir
Location: Dubai, UAE
Contact:

Broken Arabic even with config.rtl = true

#1 Post by asatiir » Sat Mar 11, 2017 8:58 am

Hi, I'm facing problems with Arabic writing on the latest version of Ren'Py (6.99.12.4.2187). I tried following the instructions in this thread and even tried asking further and got no response, so I thought I'd make a new thread explaining my problem in detail since it seems to be a different problem.

I'm using Lateef as the font in case that helps sorting this out. Whenever I write anything in Arabic, it comes out broken like this:
Image
what's written doesn't mean anything for those who can't read Arabic, but the letters need to be connected in order to be a word. I tried following the instructions in the previously mentioned thread by applying this piece of code in the script:

Code: Select all

init python:
    config.rtl = True
    style.default.font = "LateefRegOT.ttf"
which didn't help and I got this:
Image

Am I doing something wrong here?
Image
Image

User avatar
asatiir
Regular
Posts: 86
Joined: Tue Oct 01, 2013 6:04 pm
Completed: Within the Walls (Twine)
Projects: Roses Will Rise
Organization: Asatiir's Tales
Skype: asatiir
itch: asatiir
Location: Dubai, UAE
Contact:

Re: Broken Arabic even with config.rtl = true

#2 Post by asatiir » Wed Apr 12, 2017 3:48 pm

I still haven't found a solution, halp.
Image
Image

alitnk
Newbie
Posts: 1
Joined: Thu Jul 12, 2018 2:54 am
Completed: working on'em
Projects: :3
Organization: Rapid-Team
Deviantart: alitnk
Github: alitnk
Soundcloud: alitnk
Location: Iran
Contact:

Re: Broken Arabic even with config.rtl = true

#3 Post by alitnk » Thu Jul 12, 2018 2:56 am

It's just working well for me...

Post Reply

Who is online

Users browsing this forum: Yc3k