Menu movie displayable disappears [solved]

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
Amy_oai
Regular
Posts: 99
Joined: Sat Feb 21, 2015 5:02 am
Tumblr: obsessionaboutillusions
Contact:

Menu movie displayable disappears [solved]

#1 Post by Amy_oai » Sun Mar 12, 2017 4:29 am

Hi!
When returning to the main menu from the preferences screen, I'm greeted with a menu devoid of the background movie I set

This is what I'm dealing with;

This problem only occurs when I come back via the preference menu; when I open the game, the background is there and when the script runs out, the background is there.


Here's the code,
in script.rpy

Code: Select all

image main_menu = Movie(channel="main_menu", play="LakeBG0.ogv")
in screens.rpy

Code: Select all

screen main_menu:
    tag menu
    add "main_menu"

    imagemap:
        ground "images/idle1.png"
        idle "images/idle1.png"
        hover "images/selected.png"
and options.rpy

Code: Select all

mm_root = "main_menu",
gm_root = "main_menu",
I tried making the movie the ground image for the menu, but I only run into the same problem, with an even worse looking result (just hotspots being displayed)

Image
If anyone can help me out, that'd be much appreciated! ♥
Last edited by Amy_oai on Mon Mar 13, 2017 2:11 am, edited 1 time in total.
.
Image Image Image Image

User avatar
gas
Miko-Class Veteran
Posts: 532
Joined: Mon Jan 26, 2009 7:21 pm
Contact:

Re: Menu movie displayable disappears

#2 Post by gas » Sun Mar 12, 2017 2:54 pm

Rename the image into something different than "main_menu".Well, DON'T use "main_menu" name for anything else than the main menu screen itself.
It's a special name. I think that this will solve the issue.
10 ? "RENPY"
20 GOTO 10

RUN

User avatar
Amy_oai
Regular
Posts: 99
Joined: Sat Feb 21, 2015 5:02 am
Tumblr: obsessionaboutillusions
Contact:

Re: Menu movie displayable disappears [solved]

#3 Post by Amy_oai » Mon Mar 13, 2017 2:54 am

Thanks for the suggestion, gas! Just fyi it gave the same issue.
But a solution was found anyway! I totally overlooked that I was using

Code: Select all

screen main_menu:
    tag menu
so when I tried going back from the preferences menu, that one was still shown as

Code: Select all

MainMenu()
So yeah, simply was calling upon the wrong screen.

it was a dumb error on my part, thanks for trying to help out though!
.
Image Image Image Image

User avatar
Geckos
Veteran
Posts: 469
Joined: Fri Aug 17, 2012 8:33 am
Completed: Brilliant Shadows, Perceptions of the Dead, The Phantom Icecream Truck
Projects: Embers of Magic, Pale Spectrum, Perceptions of the Dead
Organization: Ithaqua Labs
Tumblr: geckosart
Deviantart: sitaart
Contact:

Re: Menu movie displayable disappears [solved]

#4 Post by Geckos » Fri Dec 22, 2017 8:08 pm

Amy_oai wrote:
Mon Mar 13, 2017 2:54 am
Thanks for the suggestion, gas! Just fyi it gave the same issue.
But a solution was found anyway! I totally overlooked that I was using

Code: Select all

screen main_menu:
    tag menu
so when I tried going back from the preferences menu, that one was still shown as

Code: Select all

MainMenu()
So yeah, simply was calling upon the wrong screen.

it was a dumb error on my part, thanks for trying to help out though!
Having the same issue here, myself!
I'm not entirely certain what you mean with your solution having been fixed by calling a different window. Any chance I could get you to show your working code?
Thanks so much!
Hope your weekend is great.
EDIT
Figured it out with

Code: Select all

    add Movie(size=(1920, 1080))
    on "show" action Play("movie", "movies/potd2_menu.webm", loop=True)
    on "hide" action Stop("movie")
    on "replace" action Play("movie", "movies/potd2_menu.webm", loop=True)
    on "replaced" action Stop("movie")
    
Image ImageImage

User avatar
Amy_oai
Regular
Posts: 99
Joined: Sat Feb 21, 2015 5:02 am
Tumblr: obsessionaboutillusions
Contact:

Re: Menu movie displayable disappears [solved]

#5 Post by Amy_oai » Sat Dec 23, 2017 2:20 am

Geckos wrote:
Fri Dec 22, 2017 8:08 pm

Having the same issue here, myself!
I'm not entirely certain what you mean with your solution having been fixed by calling a different window. Any chance I could get you to show your working code?
Thanks so much!
Hope your weekend is great.
EDIT
Figured it out with

Code: Select all

    add Movie(size=(1920, 1080))
    on "show" action Play("movie", "movies/potd2_menu.webm", loop=True)
    on "hide" action Stop("movie")
    on "replace" action Play("movie", "movies/potd2_menu.webm", loop=True)
    on "replaced" action Stop("movie")
    
I see you fixed it yourself already, but here's the distribution of the game that never was. Check out the code if you'd like, and have a great weekend yourself!
nanotest-1.0-pc.zip
(81.64 MiB) Downloaded 13 times
.
Image Image Image Image

Post Reply

Who is online

Users browsing this forum: No registered users