Side Image not appearing

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
Xerofit51
Veteran
Posts: 367
Joined: Thu Jan 09, 2014 12:58 am
Completed: Freak-quency, Harvest-Moon spin off
Projects: Freak-quency
Deviantart: xerofit51
Location: Indonesia
Contact:

Side Image not appearing

#1 Post by Xerofit51 » Tue Mar 06, 2018 11:03 pm

This is rather a weird bug. If I launch my project in the launcher, my side images works fine, but after I compile it and play it , my side images won't show, in some pcs it does. My side images are dynamic, so they place differently, depending on the character. This worked fine in my pc and launcher mode but not so in some pcs with the distributed game mode

These are how it played in my launcher
2018-03-07.png
2018-03-07 (2).png
2018-03-07 (1).png
in the distributed game, the image are gone

Here is and example of my side image code

Code: Select all

$ g = Character(None, image = "goldiesisi", color = "#ffffff", window_background="text_box_atas_kanan", window_top_padding=59 , what_xpos= 0.09, window_left_margin = 494, window_right_padding = 40,  what_ypos=0, who_ypos=5, window_yalign = 0.0)
This code maintain the side image position

Code: Select all

    if bawah:
        add SideImage() xalign 0.0 yalign 1.0
    elif kiri:
        add SideImage() xalign 0.0 yalign 0.0
    elif kanan:
        add SideImage() xalign 1.0 yalign 1.0
    else:
        add SideImage() xalign 1.0 yalign 0.0
Help? Thank You!

User avatar
Xerofit51
Veteran
Posts: 367
Joined: Thu Jan 09, 2014 12:58 am
Completed: Freak-quency, Harvest-Moon spin off
Projects: Freak-quency
Deviantart: xerofit51
Location: Indonesia
Contact:

Re: Side Image not appearing

#2 Post by Xerofit51 » Tue Mar 06, 2018 11:34 pm

Ah here's also a weird little thing about this bug, if it doesn't show up, and I open the script, either the launcher or distributed file, the side images pop out again.

Post Reply

Who is online

Users browsing this forum: adrix89, drKlauz, futurama92, Majestic-12 [Bot]