ATL flickering when transitions are used?

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
Rinzamakani
Regular
Posts: 34
Joined: Wed Aug 16, 2017 3:23 pm
Completed: Love's Apathy (Demo)
Projects: Love's Apathy (Full)
itch: rinzamakani.itch.io
Contact:

ATL flickering when transitions are used?

#1 Post by Rinzamakani » Sat Jul 07, 2018 6:27 pm

Hello. I've been trying to animate fog for my game using two png images. However, when I use the "with dissolve" command with each image in the ATL block, the frames flicker to black whether it be for a single frame or the black just takes up the entire screen once starting the game. At first, I thought it was my images that I probably had drawn on by accident, yet that doesn't seem to be the case. Both images are indeed transparent. This does NOT happen when I remove the dissolve commands. However, the fog doesn't work the way I'd like it to without the dissolves.

Here's the code I've been using.

Code: Select all

image fog:
   "Fog1.png" with dissolve
   0.50
   "Fog2.png" with dissolve
   0.50
   Repeat
And here's where I actually use the code.

Code: Select all

Scene room6 with dissolve
Show fog
Show tv with dissolve
Show snow
I find this odd since the other image I've animated with ATL works smoothly. In case it matters, I'm using Renpy version 6.99.13.2919
I've created an amino dedicated to learning Ren'py and finding resources. We need more members. Feel free to check it out!
http://aminoapps.com/invite/GLQD3S588Z

User avatar
Per K Grok
Regular
Posts: 169
Joined: Fri May 18, 2018 1:02 am
Completed: the Ghost Pilot, Sea of Lost Ships, Bubbles and the Pterodactyls
Projects: Defenders of Adacan
Deviantart: pekj
itch: per-k-grok
Location: Sverige
Contact:

Re: ATL flickering when transitions are used?

#2 Post by Per K Grok » Sun Jul 08, 2018 3:54 am

Rinzamakani wrote:
Sat Jul 07, 2018 6:27 pm
Hello. I've been trying to animate fog for my game using two png images. However, when I use the "with dissolve" command with each image in the ATL block, the frames flicker to black
---
This seems to be a limitation with an animated image using something like dissolve for the individual images in the animation.

The transparent color will show up as black (except for the first image where transparency will work).

One thing you could do is to use a graphic editor to create more images with a different mixes between the two images. That way you could create a similar effect without using dissolve.
Image Visual Story Telling, DeviantArt Group for animations, comics, games and illustrations https://www.deviantart.com/acgi

User avatar
Donmai
Eileen-Class Veteran
Posts: 1768
Joined: Sun Jun 10, 2012 1:45 am
Completed: Toire No Hanako, Li'l Red [NaNoRenO 2013], The One in LOVE [NaNoRenO 2014], Running Blade [NaNoRenO 2016], The Other Question
Projects: Slumberland
Location: Brazil
Contact:

Re: ATL flickering when transitions are used?

#3 Post by Donmai » Sun Jul 08, 2018 2:11 pm

You can also try this:

Code: Select all

image fog:
   "Fog1.png" with Dissolve(0.5, alpha = True)
   0.50
   "Fog2.png" with Dissolve(0.5, alpha = True)
   0.50
   Repeat
Image
No, sorry! You must be mistaking me for someone else.
TOIRE NO HANAKO (A Story About Fear)

User avatar
Per K Grok
Regular
Posts: 169
Joined: Fri May 18, 2018 1:02 am
Completed: the Ghost Pilot, Sea of Lost Ships, Bubbles and the Pterodactyls
Projects: Defenders of Adacan
Deviantart: pekj
itch: per-k-grok
Location: Sverige
Contact:

Re: ATL flickering when transitions are used?

#4 Post by Per K Grok » Sun Jul 08, 2018 4:59 pm

Donmai wrote:
Sun Jul 08, 2018 2:11 pm
You can also try this:

Code: Select all

image fog:
   "Fog1.png" with Dissolve(0.5, alpha = True)
   0.50
   "Fog2.png" with Dissolve(0.5, alpha = True)
   0.50
   Repeat
Obviously a better way :)

I did not realize that could work. In the manual the alpha argument is described as "ignored" which seems a bit misleading. :)
Image Visual Story Telling, DeviantArt Group for animations, comics, games and illustrations https://www.deviantart.com/acgi

User avatar
Rinzamakani
Regular
Posts: 34
Joined: Wed Aug 16, 2017 3:23 pm
Completed: Love's Apathy (Demo)
Projects: Love's Apathy (Full)
itch: rinzamakani.itch.io
Contact:

Re: ATL flickering when transitions are used?

#5 Post by Rinzamakani » Sun Jul 08, 2018 8:20 pm

Donmai wrote:
Sun Jul 08, 2018 2:11 pm
You can also try this:

Code: Select all

image fog:
   "Fog1.png" with Dissolve(0.5, alpha = True)
   0.50
   "Fog2.png" with Dissolve(0.5, alpha = True)
   0.50
   Repeat
This worked. Thanks a bunch! :D
I've created an amino dedicated to learning Ren'py and finding resources. We need more members. Feel free to check it out!
http://aminoapps.com/invite/GLQD3S588Z

Post Reply

Who is online

Users browsing this forum: Jackkel Dragon, Majestic-12 [Bot]