Lint Errors for Say with Image Attribute and LayeredImage

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
User avatar
Posts: 284
Joined: Fri Nov 27, 2015 9:02 am
Completed: Lads in Distress (NaNoRenO '16), Red String of Fate, AIRIS
Projects: Lads in Distress (Expansion), Reanimation Scheme
Organization: Wind Chimes Games

Lint Errors for Say with Image Attribute and LayeredImage

#1 Post by Windchimes » Wed Jul 18, 2018 2:21 am

Hey everyone!

So I have a bit of an odd problem right now. I just started using LayeredImage to do my sprites in Ren'Py, and everything works fine so far like this

Code: Select all

layeredimage test:
    group outfit auto
    group face auto

define t = Character("Testing", image="test")
I can change expressions just fine with

Code: Select all

show test happy
I've also been using say with image attributes to change expressions like this

Code: Select all

t happy "I am happy"
The really odd thing is — it actually works fine in game. The expressions change correctly, images show up, everything is fine. But when I run Lint, it basically spits out endless errors at me, one error for every line where I changed expressions with say statement like that:

Code: Select all

game/commonroute.rpy:68 Could not find image (test happy1) corresponding to attributes on say statement.

game/commonroute.rpy:80 Could not find image (test frown1) corresponding to attributes on say statement.

game/commonroute.rpy:82 Could not find image (test frown2) corresponding to attributes on say statement.
I searched to see if there are solutions, and I found a few old threads but no real actual solution that worked for me. I also saw one new post on Ren'Py 7.0 reporting this (viewtopic.php?t=50382#p488465). So basically I'm wondering — is this just a Lint bug that doesn't affect anything, or is this something I should actually worry about? If it works in game when I run it and only shows errors in Lint, will it work fine when I compile and distribute it? Or should I just avoid using say with attributes like that?

Thank you very much!
Image Image

User avatar
Miko-Class Veteran
Posts: 718
Joined: Mon Jan 26, 2009 7:21 pm

Re: Lint Errors for Say with Image Attribute and LayeredImage

#2 Post by gas » Wed Jul 18, 2018 8:26 am

Lint can't predict the image 'cause it's computed at runtime, just that. It's not even a bug.
If you want to debate on a reply I gave to your posts, please QUOTE ME or i'll be not notified about.

10 ? "RENPY"
20 GOTO 10


Post Reply

Who is online

Users browsing this forum: plaster