Ren'Py 7.3.5 Released

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
PyTom
Ren'Py Creator
Posts: 15431
Joined: Mon Feb 02, 2004 10:58 am
Completed: Moonlight Walks
Projects: Ren'Py
IRC Nick: renpytom
Github: renpytom
itch: renpytom
Location: Kings Park, NY
Contact:

Ren'Py 7.3.5 Released

#1 Post by PyTom » Fri Oct 18, 2019 1:22 am

I'm happy to announce Ren'Py 7.3.5, the latest in a series of releases that continue to maintain Ren'Py 7.3. This release fixes the compilation of iOS projects, and adds a button that accesses the audio directory to the launcher.

As there have been quite a few changes since Ren'Py 7.3 was originally released, please check out the changelog for new features that will help you create your visual novels and games.


Downloads of 7.3.5 can be found at:

https://www.renpy.org/release/7.3.5

A full list of changes to Ren'Py can be found at:

https://www.renpy.org/doc/html/changelog.html

A list of changes that may require you to update your game can be found at:

https://www.renpy.org/doc/html/incompatible.html

Please also check out the credits and sponsor list.
Supporting creators since 2004
(When was the last time you backed up your game?)
"Do good work." - Virgil Ivan "Gus" Grissom
"Silly and fun things are important." - Elon Musk
Software > Drama • https://www.patreon.com/renpytom

User avatar
isobellesophia
Miko-Class Veteran
Posts: 697
Joined: Mon Jan 07, 2019 2:55 am
Projects: Maddox's Everyday Talk! (13+ Unreal version), Maddox Everyday Talk! (3+ Real-Friendly version)(Upcoming 2020)
Organization: Friendly Teachers series
itch: .......
Location: Philippines, Mindanao
Contact:

Re: Ren'Py 7.3.5 Released

#2 Post by isobellesophia » Mon Oct 21, 2019 5:25 am

Thanks for updating, tested it and there were no problems after all :)


Maybe going to report once i encountered bugs.
I am a friendly user, please respect and have a good day..


Working on a talking simulation game for everyone, except children.

Maddox Everyday Talk!
Is my very very main project, not contain 13 below.

Main project here viewtopic.php?f=43&t=56564
Image

User avatar
jack_norton
Lemma-Class Veteran
Posts: 4028
Joined: Mon Jul 21, 2008 5:41 pm
Completed: Too many! See my homepage
Projects: A lot! See www.winterwolves.com
Tumblr: winterwolvesgames
Contact:

Re: Ren'Py 7.3.5 Released

#3 Post by jack_norton » Sun Dec 01, 2019 5:08 am

I have experienced a different behavior with same code, I was using 7.2- something before (I can't remember it sorry). It's some kind of ATL/alignment issue.
I have this transform code:

Code: Select all

transform cd_transform:
    # This is run before appear, show, or hide.
    xcenter 1.15 ypos 0.01 alpha 0.0

    on appear:
        linear .75 xcenter .7 alpha 1.0
    on show:
        linear .75 xcenter .7 alpha 1.0
    on hide:
        linear .75 xcenter 1.15 alpha 0.0
and I call it in various screens like:

Code: Select all

screen choose_class():
    showif pc_class == "":
        vbox at cd_transform:
            xsize 600
            frame:
                xalign 0.5 yalign 0.5 background Frame("gfx/frame4.png",120,45) ypadding 10 xpadding 100 xfill True
                text "SELECT CLASS" style "pixtext" xcenter .5 size 35
            frame:
                xfill True left_margin 15 right_margin 5 ymargin 10 background Frame("gfx/frame2.png",15,15) yminimum 500
                vbox:
                    xalign 0.5 yalign 0.5 spacing 5 xfill True
                    for i in ("Soldier","Guardian","Scout","Psionic"):
                        hbox:
                            xalign 0.5
                            $ img=im.FactorScale("gfx/class_%s.png" % i,.8)
                            imagebutton idle (im.Grayscale(img)) hover (img) xalign 0.0 action SetVariable("pc_class",i)
                            textbutton "[i]" xminimum 250 yminimum 80 text_align .5 ypadding 10 xalign 0.0 ycenter .5 action SetVariable("pc_class",i)
                    null height 50
                    frame background Frame("gfx/blueframe.png",15,15) xalign 0.5 ypadding 10:
                        text ("Click on a class to see more information.") style "smalltext" xalign 0.5
                    null height 50
    showif pc_class != "":
        vbox at cd_transform:
            xsize 600
            frame:
                xalign 0.5 yalign 0.5 background Frame("gfx/frame4.png",120,45) ypadding 10 xpadding 100 xfill True
                text "%s CLASS" % pc_class.upper() style "pixtext" xcenter .5 size 35
            if pc_class != "":
                frame:
                    xfill True xpadding 30 ypadding 25
                    vbox:
                        add "gfx/class_%s.png" % pc_class xcenter .5
                        $ desc = ClassDesc[pc_class]
                        frame xcenter .5 background Frame("gfx/frame4.png",60,15) xsize 400 xpadding 25 ypadding 15:
                            text "Class Description" xcenter .5
                        text "%s" % desc[0] xcenter .5 justify True
                        frame xcenter .5 background Frame("gfx/frame4.png",60,15) xsize 400 xpadding 25 ypadding 15:
                            text "Can Use" xcenter .5
                        text "%s" % desc[1] xcenter .5 justify True
                        frame xcenter .5 background Frame("gfx/frame4.png",60,15) xsize 400 xpadding 25 ypadding 15:
                            text "Can't Use" xcenter .5
                        text "%s" % desc[2] xcenter .5 justify True
                null height 15
                hbox xcenter .5 spacing 50:
                    textbutton "ACCEPT" action Return() xsize 200
                    textbutton "BACK" action SetVariable("pc_class","") xsize 200
the problem is that now the alignment is all messed up. And if I change the xcenter parameter on the ATL transform, nothing happens. Nothing at all. I can put xcenter .1 and it's the same as xcenter .75 which is weird!! I didn't touch this code since 1 year, so I'm not sure what was the change in Ren'Py that caused this... :?
follow me on Image Image Image Image
computer games

Post Reply

Who is online

Users browsing this forum: Dodo, Google [Bot], pistach