Defining images... how to hide group/attributes

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
bdaywans
Newbie
Posts: 15
Joined: Sat Jul 13, 2019 2:54 pm
Contact:

Defining images... how to hide group/attributes

#1 Post by bdaywans » Sat Jul 13, 2019 3:21 pm

I realized my previous issue was user error but it took re watching the tutorial that ALEX sent me to figure it out. I'm not able to call in images and change the attributes and is working fine so far. But what I'm nut sure about now is how to hide a group...

One of the part of my game will be a 'dress up' function (wardrobe selection) and I've got groups like top, bottom, and underwear. If I wanted to make the top removable entirely how do I do that? Can I do that. DO I need to make a blank option that gets called in like "character_top_blanktop" or if the option is selected, or story calls for it, can I just hide the attribute until I return to the default or call a replacement?
Last edited by bdaywans on Wed Jul 17, 2019 7:56 am, edited 2 times in total.

User avatar
Alex
Lemma-Class Veteran
Posts: 2501
Joined: Fri Dec 11, 2009 5:25 pm
Contact:

Re: Defining images... just not getting in (help?)

#2 Post by Alex » Sat Jul 13, 2019 7:51 pm

Have you seen this tutorial - viewtopic.php?f=51&t=50764#p490465?

bdaywans
Newbie
Posts: 15
Joined: Sat Jul 13, 2019 2:54 pm
Contact:

Re: Defining images... just not getting in (help?)

#3 Post by bdaywans » Sun Jul 14, 2019 12:54 am

Alex wrote:
Sat Jul 13, 2019 7:51 pm
Have you seen this tutorial - viewtopic.php?f=51&t=50764#p490465?
Thanks, while it was a helpful tutorial that was the one that I based my code off of so not sure what I'm doing wrong

bdaywans
Newbie
Posts: 15
Joined: Sat Jul 13, 2019 2:54 pm
Contact:

Re: Defining images... just not getting in (help?)

#4 Post by bdaywans » Wed Jul 17, 2019 7:56 am

Alex wrote:
Sat Jul 13, 2019 7:51 pm
Have you seen this tutorial - viewtopic.php?f=51&t=50764#p490465?
Thanks again Alex, turns out the error was on my end. My code was right, my images were wrong

User avatar
Alex
Lemma-Class Veteran
Posts: 2501
Joined: Fri Dec 11, 2009 5:25 pm
Contact:

Re: Defining images... how to hide group/attributes

#5 Post by Alex » Wed Jul 17, 2019 1:21 pm

Glad you've solved it...;)

Post Reply

Who is online

Users browsing this forum: Camuzer, Google [Bot], hell_oh_world