My images won't show up where I tell them to

Discuss how to use the Ren'Py engine to create visual novels and story-based games. New releases are announced in this section.
Forum rules
This is the right place for Ren'Py help. Please ask one question per thread, use a descriptive subject like 'NotFound error in option.rpy' , and include all the relevant information - especially any relevant code and traceback messages. Use the code tag to format scripts.
Post Reply
Message
Author
User avatar
AntisocialMilkshake
Newbie
Posts: 5
Joined: Sun Sep 29, 2019 5:53 pm
Contact:

My images won't show up where I tell them to

#1 Post by AntisocialMilkshake » Mon Sep 30, 2019 10:21 pm

I've attempted this for a while now, and I run into the same problem. I don't know how to fix it, so I've come here hoping someone can help me.

Anyway, my images are showing up fine, it's when I try to give them a place to go (such as, show yuzuki_og at right), I can't get the image to go there. It just stays in the middle of the screen. I have two characters I'm trying to show at once: Maki on the left, and Yuzuki on the right. The images just keep staying in the center.

I've looked up how to fix this, but I couldn't find anything...

If anyone could help me fix this, I'd really appreciate it!

(I'm a huge newbie to Ren'Py, so please try to explain things fairly easily ^^)

User avatar
eezergoode
Regular
Posts: 51
Joined: Tue Aug 29, 2006 10:55 am
Contact:

Re: My images won't show up where I tell them to

#2 Post by eezergoode » Mon Sep 30, 2019 10:35 pm

This may be too obvious, but since it happened to me once, I will ask.

What are the dimensions of your character sprite? I once had what I thought was a small sprite, and it turned out to be a 1080p transparent image with the character sprite in the center being the only visible thing. Since the actual dimensions were already the size of the screen, it couldn't be shifted around.
Eezergoode - AKA Rabid Penguin
Team Lead
Image
It does not matter how slowly you go so long as you do not stop.
Confucius
Chinese philosopher & reformer (551 BC - 479 BC)

User avatar
AntisocialMilkshake
Newbie
Posts: 5
Joined: Sun Sep 29, 2019 5:53 pm
Contact:

Re: My images won't show up where I tell them to

#3 Post by AntisocialMilkshake » Mon Sep 30, 2019 10:39 pm

eezergoode wrote:
Mon Sep 30, 2019 10:35 pm
This may be too obvious, but since it happened to me once, I will ask.

What are the dimensions of your character sprite? I once had what I thought was a small sprite, and it turned out to be a 1080p transparent image with the character sprite in the center being the only visible thing. Since the actual dimensions were already the size of the screen, it couldn't be shifted around.
The dimensions are the same as the screen size, haha (I'm such a newbie)

User avatar
nerupuff
Veteran
Posts: 211
Joined: Sat Dec 02, 2017 2:24 am
Projects: InTWON (Nano19)
Contact:

Re: My images won't show up where I tell them to

#4 Post by nerupuff » Mon Sep 30, 2019 10:51 pm

Once you fix the sprite dimensions, I believe that will fix the problem. Any cropping software can probably fix it so long as you maintain it as .png so you'll have the transparency.
ImageImage
Hire me for proofreading, editing, and (maybe) writing! ♡ Check here!

User avatar
isobellesophia
Miko-Class Veteran
Posts: 978
Joined: Mon Jan 07, 2019 2:55 am
Completed: None
Projects: Maddox and Friends! (AI Teacher friend), Friendly Universities! (Soon)
Organization: Friendly Teachers series
Deviantart: SophBelle
itch: Child Creation
Location: Philippines, Mindanao
Contact:

Re: My images won't show up where I tell them to

#5 Post by isobellesophia » Mon Sep 30, 2019 10:57 pm

Your image is not transparent probably, most likely i had that error from me, OR you had the same file name that makes RenPy think that the two images are exactly one in one.
I am a friendly user, please respect and have a good day.


Image

Image


User avatar
AntisocialMilkshake
Newbie
Posts: 5
Joined: Sun Sep 29, 2019 5:53 pm
Contact:

Re: My images won't show up where I tell them to

#6 Post by AntisocialMilkshake » Tue Oct 01, 2019 7:42 am

Thanks everyone! You've really helped! I'm fixing up everything now.

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot]