Error while trying to build Android package

In this forum we discuss the future of Ren'Py, both bug fixes and longer-term development. Pre-releases are announced and discussed here.
Post Reply
Message
Author
User avatar
richycapy
Regular
Posts: 47
Joined: Mon May 27, 2019 8:53 pm
Organization: EN Productions
Location: Mexico
Contact:

Error while trying to build Android package

#1 Post by richycapy » Sat May 08, 2021 12:35 am

Hello, a few mouths ago we were able to build our game into Android with no problem

Right now, we are trying with no success, this is the error that gives us, we already changes computers, internet conections, no proxis... and still no success :(

Can someone help?

Thanks!

Code: Select all

Ren'Py 7.4.4.1439



Updating project.



Creating assets directory.



Packaging internal data.



I'm using Gradle to build the package.

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/6.1.1/userguide/gradle_daemon.html.

Daemon will be stopped at the end of the build stopping after processing



> Configure project :app

WARNING: API 'ApkVariantOutput.getVersionCodeOverride()' is obsolete and has been replaced with 'VariantOutput.versionCode()'.

It will be removed in version 5.0 of the Android Gradle plugin.

Gradle Properties must be used to change Variant information.

For more information, see https://d.android.com/r/tools/use-properties.

To determine what is calling ApkVariantOutput.getVersionCodeOverride(), use -Pandroid.debug.obsoleteApi=true on the command line to display more information.



FAILURE: Build failed with an exception.



* What went wrong:

Could not determine the dependencies of task ':app:lintVitalRelease'.

> Could not resolve all artifacts for configuration ':app:debugRuntimeClasspath'.

   > Could not resolve com.danikula.expansion:expansion:1.3.4.

     Required by:

         project :app > project :renpyandroid

      > Could not resolve com.danikula.expansion:expansion:1.3.4.

         > Could not get resource 'https://dl.bintray.com/alexeydanilov/apk-expansion/com/danikula/expansion/expansion/1.3.4/expansion-1.3.4.pom'.

            > Could not HEAD 'https://dl.bintray.com/alexeydanilov/apk-expansion/com/danikula/expansion/expansion/1.3.4/expansion-1.3.4.pom'. Received status code 403 from server: Forbidden

   > Could not resolve com.danikula.expansion:license:1.7.0.

     Required by:

         project :app > project :renpyandroid

      > Could not resolve com.danikula.expansion:license:1.7.0.

         > Could not get resource 'https://dl.bintray.com/alexeydanilov/apk-expansion/com/danikula/expansion/license/1.7.0/license-1.7.0.pom'.

            > Could not HEAD 'https://dl.bintray.com/alexeydanilov/apk-expansion/com/danikula/expansion/license/1.7.0/license-1.7.0.pom'. Received status code 403 from server: Forbidden

   > Could not resolve com.danikula.expansion:zip:1.2.1.

     Required by:

         project :app > project :renpyandroid

      > Could not resolve com.danikula.expansion:zip:1.2.1.

         > Could not get resource 'https://dl.bintray.com/alexeydanilov/apk-expansion/com/danikula/expansion/zip/1.2.1/zip-1.2.1.pom'.

            > Could not HEAD 'https://dl.bintray.com/alexeydanilov/apk-expansion/com/danikula/expansion/zip/1.2.1/zip-1.2.1.pom'. Received status code 403 from server: Forbidden



* Try:

Run with --info or --debug option to get more log output. Run with --scan to get full insights.





User avatar
mavyxdawn
Regular
Posts: 68
Joined: Sun Dec 20, 2015 6:18 pm
Github: mavyxdawn
itch: zeillearnings
Discord: Zeil#4950
Contact:

Re: Error while trying to build Android package

#2 Post by mavyxdawn » Sat May 08, 2021 2:44 am

Hi! The bintray website is down and won't be coming back. That's why the download is failing. The devs are currently looking into it.
More info here: viewtopic.php?f=8&t=62051&hilit=danikula
YouTube: Zeil Learnings
itch.io: Zeil Learnings

Image

User avatar
Imperf3kt
Lemma-Class Veteran
Posts: 3413
Joined: Mon Dec 14, 2015 5:05 am
Location: Your monitor
Contact:

Re: Error while trying to build Android package

#3 Post by Imperf3kt » Sat May 08, 2021 3:31 am

A fix has already been issued, it will be in the next renpy stable release.
See this thread (and it's links) for a more detailed explanation.
viewtopic.php?f=8&t=62070#p542392
Warning: May contain trace amounts of gratuitous plot.
pro·gram·mer (noun) An organism capable of converting caffeine into code.

Free Android GUI - Updated occasionally
Twitter
Imperf3kt Blackjack - a WIP blackjack game for Android made using Ren'Py
Latest Blackjack updates

Post Reply

Who is online

Users browsing this forum: No registered users